source: branches/4.x/mkdocs @ 687

Last change on this file since 687 was 687, checked in by D'Arcy J.M. Cain, 4 years ago

The docs Makefile now requires gmake. On Linux make is gmake but on BSD
systems we need to run gmake. While not perfect, this change will check
for a separate gmake executible and use it if it exists. Also, added a
comment in Makefile to help users figure out why the error is happening.

  • Property svn:executable set to *
File size: 227 bytes
Line 
1#! /bin/sh
2
3MAKE=make
4which gmake && MAKE=gmake
5
6# small safety test
7if [ ! -f module/pgmodule.c ]
8then
9        echo "Hmmm.  Are you sure you are in the right directory?"
10        exit 1
11fi
12
13echo "Making Sphinx docs..."
14
15cd docs
16${MAKE} html
Note: See TracBrowser for help on using the repository browser.