source: trunk/.travis.yml

Last change on this file was 907, checked in by cito, 2 years ago

Travis config doesn't work with Pg 9.5 either, use 9.4 again

File size: 423 bytes
Line 
1# Travis CI configuration
2# see https://docs.travis-ci.com/user/languages/python
3
4language: python
5
6python:
7  - "2.6"
8  - "2.7"
9  - "3.3"
10  - "3.4"
11  - "3.5"
12  - "3.6"
13
14install:
15  - pip install .
16  - if [[ $TRAVIS_PYTHON_VERSION == 2.6 ]]; then pip install unittest2; fi
17
18script: python setup.py test
19
20addons:
21  postgresql: "9.4"
22
23services:
24  - postgresql
25
26before_script:
27  - psql -U postgres -c 'create database unittest'
Note: See TracBrowser for help on using the repository browser.