Changeset 270 for trunk/docs


Ignore:
Timestamp:
Feb 23, 2006, 6:32:18 AM (14 years ago)
Author:
cito
Message:

Added version informations to install.txt as well.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/docs/install.txt

    r268 r270  
    1313If you want to access remote database only, you don't need to install
    1414the full PostgreSQL server, but only the C interface (libpq).
     15
     16The current version of PyGreSQL has been tested with Python 2.4.2 and
     17PostGreSQL 8.1.3. Older version should work as well, but you will need
     18at least Python 2.1 and PostgreSQL 7.1.3.
    1519
    1620If you are using the DB-API 2.0 module you may consider installing
     
    5761You can build and install PyGreSQL using Distutils.
    5862
    59 On a Windows system, you should have the Microsoft Visual C++ compiler and
    60 the Microsoft .NET Framework SDK installed and on your search path.
     63On a Microsoft Windows system, you should have the Microsoft Visual C++ compiler
     64and the Microsoft .NET Framework SDK installed and on your search path.
    6165If you want to use the free Microsoft Visual C++ Toolkit 2003 compiler,
    6266you need to `patch distutils <http://www.vrplumber.com/programming/mstoolkit/>`_.
     
    7074    python setup.py install
    7175
    72 If you are using MinGW on a Windows system, you should edit the file
    73 "%MinGWpath%/lib/gcc/%MinGWversion%/specs" and change the entry
    74 that reads ``-lmsvcrt`` to ``-lmsvcr71``. Then use the following command
    75 to build and install PyGreSQL::
     76Note that the official Python 2.4 distribution for Microsoft Windows is now
     77using msvcr71 instead of msvcrt as its common runtime library. So, if you are
     78using MinGW to build PyGreSQL for Python 2.4 on a Windows system, you should
     79edit the file "%MinGWpath%/lib/gcc/%MinGWversion%/specs" and change the entry
     80that reads ``-lmsvcrt`` to ``-lmsvcr71``. Then use the following command to
     81build and install PyGreSQL::
    7682
    7783    python setup.py build -c mingw32 install
Note: See TracChangeset for help on using the changeset viewer.