Changeset 338


Ignore:
Timestamp:
Oct 31, 2008, 5:13:19 PM (11 years ago)
Author:
darcy
Message:

Use flag file to designate BETA.
Start preparing for version 4.0.

Location:
trunk
Files:
8 edited

Legend:

Unmodified
Added
Removed
  • trunk

    • Property svn:ignore set to
      BETA
  • trunk/docs/announce.txt

    r293 r338  
    33======================
    44
    5 ---------------------------------
    6 Release of PyGreSQL version 3.8.1
    7 ---------------------------------
     5-------------------------------
     6Release of PyGreSQL version 4.0
     7-------------------------------
    88
    9 PyGreSQL v3.8.1 has been released.
     9PyGreSQL v4.0 has been released.
    1010
    11 It is available at: ftp://ftp.PyGreSQL.org/pub/distrib/PyGreSQL-3.8.1.tgz.
     11It is available at: ftp://ftp.PyGreSQL.org/pub/distrib/PyGreSQL-4.0.tgz.
    1212
    1313If you are running NetBSD, look in the packages directory under databases.
  • trunk/docs/changelog.txt

    r334 r338  
    33==================
    44
    5 Version 3.8.2 (?)
    6 -----------------
     5Version 4.0 (?)
     6---------------
     7- Dropped support for Python below 2.3 and PostgreSQL below 7.2
    78- Added new method to get parameter settings.
    89- Added row_factory as suggested by Simon Pamies.
  • trunk/docs/index.html

    r295 r338  
    9595
    9696  <div id="title">PyGreSQL</div>
    97   <div id="version">Version 3.8.1</div>
     97  <div id="version">Version 4.0</div>
    9898  <div id="banner"></div>
    9999  <div id="bannertext">:: PostgreSQL module for Python ::</div>
  • trunk/docs/readme.txt

    r306 r338  
    33==========================================
    44
    5 ----------------------
    6 PyGreSQL version 3.8.1
    7 ----------------------
     5--------------------
     6PyGreSQL version 4.0
     7--------------------
    88
    99.. meta::
     
    7474version 2.0 and serves as the "BDFL" of PyGreSQL.
    7575
    76 The current version PyGreSQL 3.8.1 needs PostgreSQL 7.1.3 and Python 2.1 or above.
     76The current version PyGreSQL 4.0 needs PostgreSQL 7.2 and Python 2.3 or above.
    7777
    7878
     
    104104  http://www.freebsd.org/cgi/cvsweb.cgi/ports/databases/py-PyGreSQL/
    105105A **Win32 package** is available at
    106   ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.win32-py2.2.exe
    107 
    108   ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.win32-py2.3.exe
    109 
    110   ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.win32-py2.4.exe
    111 
    112   ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.win32-py2.5.exe
     106  ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-4.0.win32-py2.2.exe
     107
     108  ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-4.0.win32-py2.3.exe
     109
     110  ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-4.0.win32-py2.4.exe
     111
     112  ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-4.0.win32-py2.5.exe
    113113
    114114
  • trunk/mktar

    r322 r338  
    11#! /bin/sh
    22
    3 BETA=YES
    4 VERSION=3.8.2
     3VERSION=4.0
    54
    65# small safety test
     
    1110fi
    1211
    13 if [ $BETA = "YES" ]
     12if [ -f BETA ]
    1413then
    1514        VERSION=$VERSION-pre`date +"%y%m%d"`
  • trunk/module/pgmodule.c

    r331 r338  
    11/*
    2  * $Id: pgmodule.c,v 1.80 2008-09-22 19:21:01 cito Exp $
     2 * $Id: pgmodule.c,v 1.81 2008-10-31 21:13:19 darcy Exp $
    33 * PyGres, version 2.2 A Python interface for PostgreSQL database. Written by
    44 * D'Arcy J.M. Cain, (darcy@druid.net).  Based heavily on code written by
     
    5252        *IntegrityError, *DataError, *NotSupportedError;
    5353
    54 static const char *PyPgVersion = "3.8.1";
     54static const char *PyPgVersion = "4.0";
    5555
    5656/* taken from fileobject.c */
  • trunk/module/setup.py

    r337 r338  
    11#!/usr/bin/env python
    2 # $Id: setup.py,v 1.23 2008-10-31 17:26:22 cito Exp $
     2# $Id: setup.py,v 1.24 2008-10-31 21:13:19 darcy Exp $
    33
    4 """Setup script for PyGreSQL version 3.8.1
     4"""Setup script for PyGreSQL version 4.0
    55
    66Authors and history:
     
    1818  (the Windows installer has it as part of the database server feature)
    1919
    20 Tested with Python 2.4.3 and PostGreSQL 8.1.4. Older version should work
    21 as well, but you will need at least Python 2.1 and PostgreSQL 7.1.3.
     20Tested with Python 2.5.2 and PostGreSQL 8.2.10. Older version should work
     21as well, but you will need at least Python 2.3 and PostgreSQL 7.2.
    2222
    2323Use as follows:
     
    9797setup(
    9898        name = "PyGreSQL",
    99         version = "3.8.1",
     99        version = "4.0",
    100100        description = "Python PostgreSQL Interfaces",
    101101        author = "D'Arcy J. M. Cain",
Note: See TracChangeset for help on using the changeset viewer.