Changeset 449 for trunk/docs


Ignore:
Timestamp:
Oct 30, 2012, 12:33:31 PM (7 years ago)
Author:
darcy
Message:

Start 4.1 release.
Set EOL for Python and PostgreSQL versions.
Update copyrights and dates.

Location:
trunk/docs
Files:
5 edited

Legend:

Unmodified
Added
Removed
  • trunk/docs/changelog.txt

    r447 r449  
    33==================
    44
    5 Version 4.x
     5Version 4.1 (2012-12-01)
    66-----------
     7- Dropped support for Python below 2.5 and PostgreSQL below 8.3.
    78- Support the new PostgreSQL versions 9.0 and 9.1.
    89- Particularly, support PQescapeLiteral() and PQescapeIdentifier().
  • trunk/docs/index.html

    r448 r449  
    9595
    9696  <div id="title">PyGreSQL</div>
    97   <div id="version">Version 4.0</div>
     97  <div id="version">Version 4.1</div>
    9898  <div id="banner"></div>
    9999  <div id="bannertext">:: PostgreSQL module for Python ::</div>
     
    110110
    111111    <p>This software is copyright &copy; 1995, Pascal Andre.<br />
    112     Further modifications are copyright &copy; 1997-2006 by D'Arcy J.M. Cain.</p>
     112    Further modifications are copyright &copy; 1997-2008 by D'Arcy J.M. Cain.<br />
     113    Further modifications are copyright &copy; 2009-2012 by the PyGreSQL team</p>
    113114
    114115    <p>See the
     
    177178  <div id="copyright">
    178179  Created and maintained by D'Arcy J.M. Cain &ndash;
    179   last update: 6 July 2010.<br />
     180  last update: $Date$.<br />
    180181  If you have any comments, <a href="mailto:darcy@PyGreSQL.org">send mail</a> to me.
    181182  </div>
  • trunk/docs/install.txt

    r362 r449  
    1616``PATH`` environment variable.
    1717
    18 The current version of PyGreSQL has been tested with Python 2.5 and
    19 PostGreSQL 8.3. Older version should work as well, but you will need
    20 at least Python 2.3 and PostgreSQL 7.4.
     18The current version of PyGreSQL has been tested with Python 2.7 and
     19PostGreSQL 9.2. Older version should work as well, but you will need
     20at least Python 2.5 and PostgreSQL 8.3.
    2121
    2222PyGreSQL will be installed as three modules, a dynamic module called
     
    123123    -DNO_PQSOCKET  if running an older PostgreSQL
    124124
    125   Define ``NO_PQSOCKET`` if you are using a version of PostgreSQL before 6.4
    126   that does not have the PQsocket function. The other options will be
    127   described in the next sections.
    128 
    129125  On some systems you may need to include ``-lcrypt`` in the list of libraries
    130126  to make it compile.
  • trunk/docs/pg.txt

    r447 r449  
    991991  The dictionary is then, if possible, reloaded with the values actually
    992992  inserted in order to pick up values modified by rules, triggers, etc.
    993 
    994   Due to the way that this function works in PostgreSQL versions below
    995   8.2, you may find inserts taking longer and longer as your table gets
    996   bigger.  If this happens and it is a table with OID but no primary key
    997   you can overcome this problem by simply adding an index onto the OID of
    998   any table that you think may get large over time. You may also consider
    999   using the inserttable() method described in section 3.
    1000 
    1001   Note: With PostgreSQL versions before 8.2 the table being inserted to
    1002   must have a primary key or an OID to use this method properly.  If not
    1003   then the dictionary will not be filled in as described.  Also, if this
    1004   method is called within a transaction, the transaction will abort.
    1005993
    1006994  Note: The method currently doesn't support insert into views
  • trunk/docs/readme.txt

    r448 r449  
    44
    55--------------------
    6 PyGreSQL version 4.0
     6PyGreSQL version 4.1
    77--------------------
    88
     
    2424
    2525Further modifications copyright (c) 1997-2008 by D'Arcy J.M. Cain
    26 (darcy@druid.net)
     26(darcy@PyGreSQL.org)
     27
     28Further modifications copyright (c) 2009-2012 by the PyGreSQL team.
    2729
    2830Permission to use, copy, modify, and distribute this software and its
     
    7577version 2.0 and serves as the "BDFL" of PyGreSQL.
    7678
    77 The current version PyGreSQL 4.0 needs PostgreSQL 7.2 and Python 2.3 or above.
     79The current version PyGreSQL 4.1 needs PostgreSQL 8.3 and Python 2.5 or above.
    7880
    7981
     
    105107  * http://www.freebsd.org/cgi/cvsweb.cgi/ports/databases/py-PyGreSQL/
    106108A **Win32 package** for various Python versions is available at
    107   * http://pygresql.org/files/PyGreSQL-4.0.win32-py2.3.exe
    108   * http://pygresql.org/files/PyGreSQL-4.0.win32-py2.4.exe
    109   * http://pygresql.org/files/PyGreSQL-4.0.win32-py2.5.exe
    110   * http://pygresql.org/files/PyGreSQL-4.0.win32-py2.6.exe
     109  * http://pygresql.org/files/PyGreSQL-4.1.win32-py2.5.exe
     110  * http://pygresql.org/files/PyGreSQL-4.1.win32-py2.6.exe
     111  * http://pygresql.org/files/PyGreSQL-4.1.win32-py2.7.exe
    111112You can also find PyGreSQL on the **Python Package Index** at
    112113 * http://pypi.python.org/pypi/PyGreSQL/
Note: See TracChangeset for help on using the changeset viewer.