Changeset 553 for trunk/docs


Ignore:
Timestamp:
Nov 20, 2015, 6:16:03 AM (4 years ago)
Author:
cito
Message:

Require at least Python 2.6 for the trunk (5.x)

Support for even older Python versions is maintained in the 4.x branch.
The goal for 5.x is to be a single-source code for both Python 2 and 3,
and this is only possible by dropping support for Python 2.5 and older.
For instance, the new except .. as syntax works only since Python 2.6.
Otherwise we would need to use 2to3 and things would be very ugly.
Note that Python 2.6 is now 7 years old. We may want to drop Python 2.6
as well at some point if it turns out to be a burden.

Location:
trunk/docs
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • trunk/docs/install.rst

    r516 r553  
    1212
    1313The current version of PyGreSQL has been tested with Python 2.7 and
    14 PostGreSQL 9.2. Older version should work as well, but you will need
    15 at least Python 2.5 and PostgreSQL 8.3.
     14PostGreSQL 9.4. Older version should work as well, but you will need
     15at least Python 2.6 and PostgreSQL 9.0.
    1616
    1717PyGreSQL will be installed as three modules, a dynamic module called
  • trunk/docs/install.txt

    r516 r553  
    1717
    1818The current version of PyGreSQL has been tested with Python 2.7 and
    19 PostGreSQL 9.2. Older version should work as well, but you will need
    20 at least Python 2.5 and PostgreSQL 8.3.
     19PostGreSQL 9.4. Older version should work as well, but you will need
     20at least Python 2.6 and PostgreSQL 9.0.
    2121
    2222PyGreSQL will be installed as three modules, a dynamic module called
  • trunk/docs/introduction.rst

    r516 r553  
    3939version 2.0 and serves as the "BDFL" of PyGreSQL.
    4040
    41 The current version PyGreSQL 4.2 needs PostgreSQL 8.3 and Python 2.5 or above.
     41The current version PyGreSQL 5.0 needs PostgreSQL 9.0 and Python 2.6 or above.
  • trunk/docs/readme.txt

    r516 r553  
    7878version 2.0 and serves as the "BDFL" of PyGreSQL.
    7979
    80 The current version PyGreSQL 4.2 needs PostgreSQL 8.3 and Python 2.5 or above.
     80The current version PyGreSQL 5.0 needs PostgreSQL 9.0 and Python 2.6 or above.
    8181
    8282
Note: See TracChangeset for help on using the changeset viewer.