Changeset 687 for branches/4.x


Ignore:
Timestamp:
Jan 2, 2016, 11:02:40 AM (4 years ago)
Author:
darcy
Message:

The docs Makefile now requires gmake. On Linux make is gmake but on BSD
systems we need to run gmake. While not perfect, this change will check
for a separate gmake executible and use it if it exists. Also, added a
comment in Makefile to help users figure out why the error is happening.

Location:
branches/4.x
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/4.x/docs/Makefile

    r669 r687  
    11# Makefile for Sphinx documentation
    2 #
     2# -*- Note: requires GNU Make -*-
    33
    44# You can set these variables from the command line.
  • branches/4.x/mkdocs

    r674 r687  
    11#! /bin/sh
     2
     3MAKE=make
     4which gmake && MAKE=gmake
    25
    36# small safety test
     
    1114
    1215cd docs
    13 make html
     16${MAKE} html
Note: See TracChangeset for help on using the changeset viewer.