Changeset 691 for branches/4.x


Ignore:
Timestamp:
Jan 2, 2016, 6:35:15 PM (4 years ago)
Author:
cito
Message:

Print a warning when the PostgreSQL version is too old

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/4.x/module/setup.py

    r690 r691  
    4848import os
    4949import platform
     50import warnings
    5051try:
    5152    from setuptools import setup
     
    7677            part = int(part)
    7778        parts.append(part)
    78     return tuple(parts or [8])
     79    return tuple(parts or [8, 3])
    7980
    8081
     
    119120        self.default_vars = True
    120121        self.escaping_funcs = pg_version[0] >= 9
     122        if pg_version < (8, 3):
     123            warnings.warn("PygreSQL does not support this PostgreSQL version.")
    121124
    122125    def finalize_options(self):
Note: See TracChangeset for help on using the changeset viewer.