Changeset 905 for trunk


Ignore:
Timestamp:
Jan 6, 2017, 12:18:34 PM (3 years ago)
Author:
cito
Message:

Support Python 3.6 and PostgreSQL 9.6

Location:
trunk
Files:
7 edited

Legend:

Unmodified
Added
Removed
  • trunk/.travis.yml

    r859 r905  
    1010  - "3.4"
    1111  - "3.5"
     12  - "3.6"
    1213
    1314install:
     
    1819
    1920addons:
    20   postgresql: "9.4"
     21  postgresql: "9.6"
    2122
    2223services:
  • trunk/docs/announce.rst

    r896 r905  
    2626 - Ubuntu
    2727 - Windows 7 with both MinGW and Visual Studio
    28  - PostgreSQL 9.0 to 9.5 32 and 64bit
    29  - Python 2.6, 2.7, 3.3, 3.4 and 3.5 32 and 64bit
     28 - PostgreSQL 9.0 to 9.6 32 and 64bit
     29 - Python 2.6, 2.7, 3.3, 3.4, 3.5, 3.6 32 and 64bit
    3030
    3131| D'Arcy J.M. Cain
  • trunk/docs/contents/changelog.rst

    r901 r905  
    44Version 5.0.4 (to be released)
    55------------------------------
     6- This version officially supports the new Python 3.6 and PostgreSQL 9.6.
    67- query_formatted() can now be used without parameters.
    78- The automatic renaming of columns that are invalid as field names of
  • trunk/docs/contents/install.rst

    r713 r905  
    1212
    1313The current version of PyGreSQL has been tested with Python versions
    14 2.6, 2.7, 3.3, 3.4, 3.5 and PostGreSQL version 9.0 to 9.5.
     142.6, 2.7, 3.3 to 3.6 and PostGreSQL version 9.0 to 9.6.
    1515
    1616PyGreSQL will be installed as three modules, a dynamic module called
  • trunk/docs/contents/pg/adaptation.rst

    r895 r905  
    364364
    365365However, calculating the intersection points between the two circles using the
    366 ``#`` operator does not work (at least not as of PostgreSQL version 9.5).
     366``#`` operator does not work (at least not as of PostgreSQL version 9.6).
    367367So let' resort to SymPy to find out.  To ease importing circles from
    368368PostgreSQL to SymPy, we create and register the following typecast function::
  • trunk/setup.py

    r898 r905  
    2222  (the Windows installer has it as part of the database server feature)
    2323
    24 The supported versions are Python 2.6-2.7, 3.3-3.5 and PostgreSQL 9.0-9.5.
     24The supported versions are Python 2.6-2.7, 3.3-3.6 and PostgreSQL 9.0-9.6.
    2525
    2626Use as follows:
  • trunk/tox.ini

    r711 r905  
    22
    33[tox]
    4 envlist = py{26,27,33,34,35}
     4envlist = py{26,27,33,34,35,36}
    55
    66[testenv]
     
    99commands =
    1010    py26: unit2 discover []
    11     py{27,33,34,35}: python -m unittest discover []
     11    py{27,33,34,35,36}: python -m unittest discover []
Note: See TracChangeset for help on using the changeset viewer.