Changeset 940


Ignore:
Timestamp:
Jul 8, 2018, 10:48:06 AM (5 months ago)
Author:
cito
Message:

Prepare for version 5.0.6

Files:
18 edited

Legend:

Unmodified
Added
Removed
  • branches/5.0.x/docs/about.txt

    r930 r940  
    3737version 2.0 and serves as the "BDFL" of PyGreSQL.
    3838
    39 The current version PyGreSQL 5.0.5 needs PostgreSQL 9.0 to 9.6 or 10, and
    40 Python 2.6, 2.7 or 3.3 to 3.6. If you need to support older PostgreSQL versions
     39The current version PyGreSQL 5.0.6 needs PostgreSQL 9.0 to 9.6 or 10, and
     40Python 2.6, 2.7 or 3.3 to 3.7. If you need to support older PostgreSQL versions
    4141or older Python 2.x versions, you can resort to the PyGreSQL 4.x versions that
    4242still support them.
  • branches/5.0.x/docs/announce.rst

    r930 r940  
    44
    55---------------------------------
    6 Release of PyGreSQL version 5.0.5
     6Release of PyGreSQL version 5.0.6
    77---------------------------------
    88
    9 Release 5.0.5 of PyGreSQL.
     9Release 5.0.6 of PyGreSQL.
    1010
    11 It is available at: http://pygresql.org/files/PyGreSQL-5.0.5.tar.gz.
     11It is available at: http://pygresql.org/files/PyGreSQL-5.0.6.tar.gz.
    1212
    1313If you are running NetBSD, look in the packages directory under databases.
     
    2727 - Windows 7 and 10 with both MinGW and Visual Studio
    2828 - PostgreSQL 9.0 to 9.6 and 10 (32 and 64bit)
    29  - Python 2.6, 2.7 and 3.3 to 3.6 (32 and 64bit)
     29 - Python 2.6, 2.7 and 3.3 to 3.7 (32 and 64bit)
    3030
    3131| D'Arcy J.M. Cain
  • branches/5.0.x/docs/conf.py

    r930 r940  
    7171version = '5.0'
    7272# The full version, including alpha/beta/rc tags.
    73 release = '5.0.5'
     73release = '5.0.6'
    7474
    7575# The language for content autogenerated by Sphinx. Refer to documentation
  • branches/5.0.x/docs/contents/changelog.rst

    r930 r940  
    22=========
    33
    4 Version 5.0.5 (to be released)
    5 ------------------------------
     4Vesion 5.0.6 (to be released)
     5-----------------------------
     6- This version officially supports the new Python 3.7.
     7- Correct trove classifier for the PostgreSQL License.
     8
     9Version 5.0.5 (2018-04-25)
     10--------------------------
    611- This version officially supports the new PostgreSQL 10.
    712- The memory for the string with the number of rows affected by a classic pg
  • branches/5.0.x/docs/contents/install.rst

    r930 r940  
    1212
    1313The current version of PyGreSQL has been tested with Python versions
    14 2.6, 2.7 and 3.3 to 3.6, and PostGreSQL versions 9.0 to 9.6 and 10.
     142.6, 2.7 and 3.3 to 3.7, and PostGreSQL versions 9.0 to 9.6 and 10.
    1515
    1616PyGreSQL will be installed as three modules, a dynamic module called
  • branches/5.0.x/docs/download/download.rst

    r930 r940  
    1818  * https://software.opensuse.org/package/PyGreSQL?search_term=pygresql
    1919A **Win32 installer** for various Python versions is available at
    20   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py2.6.exe
    21   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py2.7.exe
    22   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.4.exe
    23   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.5.exe
    24   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.6.exe
     20  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py2.6.exe
     21  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py2.7.exe
     22  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.4.exe
     23  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.5.exe
     24  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.6.exe
     25  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.7.exe
    2526
    2627Older PyGreSQL versions
  • branches/5.0.x/mktar

    r930 r940  
    11#! /bin/sh
    22
    3 VERSION=5.0.5
     3VERSION=5.0.6
    44DISTDIR=/u/WEB/pyg/files
    55
  • branches/5.0.x/setup.py

    r939 r940  
    22# $Id$
    33
    4 """Setup script for PyGreSQL version 5.0.5
     4"""Setup script for PyGreSQL version 5.0.6
    55
    66PyGreSQL is an open-source Python module that interfaces to a
     
    2222  (the Windows installer has it as part of the database server feature)
    2323
    24 PyGreSQL currently supports Python versions 2.6, 2.7 and 3.3 to 3.6,
     24PyGreSQL currently supports Python versions 2.6, 2.7 and 3.3 to 3.7,
    2525and PostgreSQL versions 9.0 to 9.6 and 10.
    2626
     
    3434"""
    3535
    36 version = '5.0.5'
     36version = '5.0.6'
    3737
    3838
     
    206206        'Programming Language :: Python :: 3.5',
    207207        'Programming Language :: Python :: 3.6',
     208        'Programming Language :: Python :: 3.7',
    208209        "Programming Language :: SQL",
    209210        "Topic :: Database",
  • branches/5.0.x/tox.ini

    r905 r940  
    1 # config file for tox 2.0
     1# config file for tox 2
    22
    33[tox]
    4 envlist = py{26,27,33,34,35,36}
     4envlist = py{26,27,33,34,35,36,37}
    55
    66[testenv]
     
    99commands =
    1010    py26: unit2 discover []
    11     py{27,33,34,35,36}: python -m unittest discover []
     11    py{27,33,34,35,36,37}: python -m unittest discover []
  • trunk/docs/about.txt

    r930 r940  
    3737version 2.0 and serves as the "BDFL" of PyGreSQL.
    3838
    39 The current version PyGreSQL 5.0.5 needs PostgreSQL 9.0 to 9.6 or 10, and
    40 Python 2.6, 2.7 or 3.3 to 3.6. If you need to support older PostgreSQL versions
     39The current version PyGreSQL 5.0.6 needs PostgreSQL 9.0 to 9.6 or 10, and
     40Python 2.6, 2.7 or 3.3 to 3.7. If you need to support older PostgreSQL versions
    4141or older Python 2.x versions, you can resort to the PyGreSQL 4.x versions that
    4242still support them.
  • trunk/docs/announce.rst

    r930 r940  
    44
    55---------------------------------
    6 Release of PyGreSQL version 5.0.5
     6Release of PyGreSQL version 5.0.6
    77---------------------------------
    88
    9 Release 5.0.5 of PyGreSQL.
     9Release 5.0.6 of PyGreSQL.
    1010
    11 It is available at: http://pygresql.org/files/PyGreSQL-5.0.5.tar.gz.
     11It is available at: http://pygresql.org/files/PyGreSQL-5.0.6.tar.gz.
    1212
    1313If you are running NetBSD, look in the packages directory under databases.
     
    2727 - Windows 7 and 10 with both MinGW and Visual Studio
    2828 - PostgreSQL 9.0 to 9.6 and 10 (32 and 64bit)
    29  - Python 2.6, 2.7 and 3.3 to 3.6 (32 and 64bit)
     29 - Python 2.6, 2.7 and 3.3 to 3.7 (32 and 64bit)
    3030
    3131| D'Arcy J.M. Cain
  • trunk/docs/conf.py

    r930 r940  
    7171version = '5.0'
    7272# The full version, including alpha/beta/rc tags.
    73 release = '5.0.5'
     73release = '5.0.6'
    7474
    7575# The language for content autogenerated by Sphinx. Refer to documentation
  • trunk/docs/contents/changelog.rst

    r936 r940  
    22=========
    33
     4Vesion 5.0.6 (to be released)
     5-----------------------------
     6- This version officially supports the new Python 3.7.
     7- Correct trove classifier for the PostgreSQL License.
     8
    49Version 5.0.5 (2018-04-25)
    5 ------------------------------
     10--------------------------
    611- This version officially supports the new PostgreSQL 10.
    712- The memory for the string with the number of rows affected by a classic pg
  • trunk/docs/contents/install.rst

    r930 r940  
    1212
    1313The current version of PyGreSQL has been tested with Python versions
    14 2.6, 2.7 and 3.3 to 3.6, and PostGreSQL versions 9.0 to 9.6 and 10.
     142.6, 2.7 and 3.3 to 3.7, and PostGreSQL versions 9.0 to 9.6 and 10.
    1515
    1616PyGreSQL will be installed as three modules, a dynamic module called
  • trunk/docs/download/download.rst

    r930 r940  
    1818  * https://software.opensuse.org/package/PyGreSQL?search_term=pygresql
    1919A **Win32 installer** for various Python versions is available at
    20   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py2.6.exe
    21   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py2.7.exe
    22   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.4.exe
    23   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.5.exe
    24   * http://pygresql.org/files/PyGreSQL-5.0.5.win-amd64-py3.6.exe
     20  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py2.6.exe
     21  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py2.7.exe
     22  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.4.exe
     23  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.5.exe
     24  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.6.exe
     25  * http://pygresql.org/files/PyGreSQL-5.0.6.win-amd64-py3.7.exe
    2526
    2627Older PyGreSQL versions
  • trunk/mktar

    r930 r940  
    11#! /bin/sh
    22
    3 VERSION=5.0.5
     3VERSION=5.0.6
    44DISTDIR=/u/WEB/pyg/files
    55
  • trunk/setup.py

    r939 r940  
    22# $Id$
    33
    4 """Setup script for PyGreSQL version 5.0.5
     4"""Setup script for PyGreSQL version 5.0.6
    55
    66PyGreSQL is an open-source Python module that interfaces to a
     
    2222  (the Windows installer has it as part of the database server feature)
    2323
    24 PyGreSQL currently supports Python versions 2.6, 2.7 and 3.3 to 3.6,
     24PyGreSQL currently supports Python versions 2.6, 2.7 and 3.3 to 3.7,
    2525and PostgreSQL versions 9.0 to 9.6 and 10.
    2626
     
    3434"""
    3535
    36 version = '5.0.5'
     36version = '5.0.6'
    3737
    3838
     
    206206        'Programming Language :: Python :: 3.5',
    207207        'Programming Language :: Python :: 3.6',
     208        'Programming Language :: Python :: 3.7',
    208209        "Programming Language :: SQL",
    209210        "Topic :: Database",
  • trunk/tox.ini

    r905 r940  
    1 # config file for tox 2.0
     1# config file for tox 2
    22
    33[tox]
    4 envlist = py{26,27,33,34,35,36}
     4envlist = py{26,27,33,34,35,36,37}
    55
    66[testenv]
     
    99commands =
    1010    py26: unit2 discover []
    11     py{27,33,34,35,36}: python -m unittest discover []
     11    py{27,33,34,35,36,37}: python -m unittest discover []
Note: See TracChangeset for help on using the changeset viewer.