Opened 9 years ago

Closed 7 years ago

#31 closed task (fixed)

Define the required Pg and Py versions for Pygres 4.1

Reported by: cito Owned by: darcy
Priority: critical Milestone: 4.1
Component: DB API 2 Version: 4.0
Keywords: Cc:

Description

We must define the minimum required Postgres and Python versions for PyGreSQL 4.1. Do we still want to support Pg 7.4 and Python 2.3?

We should drop support for the very old versions at least in Pygres 4.1 and 5.0. This will result in some noticeable simplifications in the C and Python code, and maybe we can support newer constructs such as "with" (#20) and named tuples (#22) instead.

Change History (2)

comment:1 Changed 8 years ago by darcy

The final release of Python 2.4 was 2.4.6 on December 19, 2008. We can probably drop support for anything less than 2.5 now.

For PostgreSQL anything less than 8.2 has already reached EOL and 8.2 drops this year.

comment:2 Changed 7 years ago by darcy

  • Resolution set to fixed
  • Status changed from new to closed

I have selected Python 2.5 and PostgreSQL 8.3 as the oldest supported versions.

Note: See TracTickets for help on using tickets.