Opened 4 years ago

Closed 4 years ago

#60 closed task (fixed)

Document/solve possible issues regarding OIDs

Reported by: cito Owned by:
Priority: major Milestone: 5.0
Component: Classic API Version: 4.1
Keywords: oids docs Cc:

Description

PostgreSQL stopped adding OIDs to user tables by default since version 8.1.

However, the classic pg module still makes use of OIDs in several places. We should document exactly where it relies on OIDs and what problems can appear when your tables do not have OIDs. Maybe we can also improve the classic pg module so that it becomes less dependent on OIDs. Should we recommend setting DEFAULT_WITH_OIDS=TRUE when creating tables supposed to work with the classic pg module? Note that there are certainly valid reasons why OIDs have been deprecated for user tables.

See also

Change History (3)

comment:1 Changed 4 years ago by darcy

I use the classic module all the time and the only time that I need OIDs is when I don't have a primary key. Even then I don't need it for regular queries. I can't remember the time that I needed OIDs in any of my tables.

comment:2 Changed 4 years ago by cito

Yes, this is only a reminder that I wanted to go through the source code of the DB class and look exactly in which cases the absence of OIDs could cause problems that are not already mentioned in the docs.

comment:3 Changed 4 years ago by cito

  • Resolution set to fixed
  • Status changed from new to closed

Checked everything in r729 and removed some overhead caused by adding qualified table names to OID key names, since OIDs are not widely used any more.

Note: See TracTickets for help on using tickets.